Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hi, I Faced With A Silly Error, When I Run The Python Script With Task = Trains.Init(Project_Name='My Project', Task_Name='My Task'). The Task Goes To The Trains Server, But In The Trains Server, In Installed Packages Part One Of The Line

Hi, I faced with a silly error, when I run the python script with task = trains.init(project_name='my project', task_name='my task'). The task goes to the trains server, but in the trains server, in installed packages part one of the line -e git+ https://github.com/allegroai/trains.git@master#egg=trains brokes my execution. If I delete this line it works. I want to avoid occurrence of this line.

  
  
Posted 3 years ago
Votes Newest

Answers 15


Hi MysteriousBee56 , do you have Trains installed from the git?
Another question, you mentioned "it breaks my execution", I'm assuming you mean trains-agent?!
If that is the case, there is a fix for trains-agent install 0.15.2rc0

  
  
Posted 3 years ago

I will install from repository and try it again, my trains-agent version is 0.15.2rc0, but I could not find trains version, it might be about version

  
  
Posted 3 years ago

Yes, I mean trains-agent. Actually I am using 0.15.2rc0. But, I am using local files, I mean I clone trains and trains-agent repos and install them. Their versions are 0.15.2rc0

I see, that's why we get the git ref, not package version.

  
  
Posted 3 years ago

I think it fails because it tries to install trains twice. Could you remove the trains package, and test? I'm also curious how do you have both installed?!

  
  
Posted 3 years ago

-e git+ torch == 1.5.1 torchvision == 0.6.1 trains == 0.15.2rc0Actually, package version is also written. However, because of git ref, trains-agent fails.

  
  
Posted 3 years ago

MysteriousBee56 yes, please change the trains code!!! Wee pee, if you think someone else can benefit, feel free to PR :)
Regrading the double entry, that seems like an odd bug, how can I reproduce it?

  
  
Posted 3 years ago

Yes, found the issue :) I'll see to it there is a fix in the next RC. ETA early next week

  
  
Posted 3 years ago

Yep, still getting the double package.

  
  
Posted 3 years ago

I think you can reproduce it by cloning the trains repository, then pip install -e ~/trains and then you need to run one of the examples from trains examples by writing python3 toy_base_task.py . Then you should see this odd bug.

  
  
Posted 3 years ago

did you reproduce the error?

  
  
Posted 3 years ago

Yes, I mean trains-agent. Actually I am using 0.15.2rc0. But, I am using local files, I mean I clone trains and trains-agent repos and install them. Their versions are 0.15.2rc0

  
  
Posted 3 years ago

Yes, it fixed. If I install trains from github repo directly withouth using my local version. But, is there another way to avoid it, because I might change the code for my personal use, that's why I want to install trains from my local.

  
  
Posted 3 years ago

The versions don't need to match, any combination will work.

  
  
Posted 3 years ago

Thanks@doru! BTW if you are running a code from outside the trains repo, do you still get the double package?

  
  
Posted 3 years ago

Thanks :)

  
  
Posted 3 years ago
704 Views
15 Answers
3 years ago
one year ago
Tags
Similar posts