Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hi Team,In Clearml.Config File Can We Change This

Hi Team,in clearml.config file can we change this settings as i want to utlize cpu instead of gpu
default_docker: {
# default docker image to use when running in docker mode
image: "nvidia/cuda:10.2-cudnn7-runtime-ubuntu18.04"

    # optional arguments to pass to docker image
    # arguments: ["--ipc=host", ]
}
  
  
Posted one year ago
Votes Newest

Answers 7


Hi SuperiorCockroach75 , yes you can use any docker image you want 🙂

  
  
Posted one year ago

@<1523701070390366208:profile|CostlyOstrich36> While running pipeline.py for the asteroid_example.
It worked for this: pipe.start_locally(run_pipeline_steps_locally=True)

But it's in pending state only while running with pipe.start().

ClearML Task: created new task id=0f27eae0f8a34605870ebbf41a2ad128
ClearML results page: 

ClearML pipeline page: 

Switching to remote execution, output log page 

Terminating local execution process
  
  
Posted one year ago

Hi @<1533159639040921600:profile|JoyousReindeer30> , the pipeline controller is currently pending. I am guessing it is enqueued into the services queue. You would need to run an agent on the services queue for the pipeline to start executing 🙂

  
  
Posted one year ago

pipeline gets created but execution not happening...
image

  
  
Posted one year ago

@<1533159639040921600:profile|JoyousReindeer30> , you need to run the agent with the -- cpu-only tag as well 🙂

  
  
Posted one year ago

python:3.7
Status: Downloaded newer image for python:3.7
docker: Error response from daemon: could not select device driver "" with capabilities: [[gpu]].

@John C. where to configure if agent is not having gpu?
  
  
Posted one year ago

Agent is also running:
clearml-agent daemon --queue default services --foreground --docker python:new --cpu-only

but agent setting stucked at this pip warning
image
image

  
  
Posted one year ago