Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Separate Problem From The Above. I Cannot Get The Clearml-Init Command To Accept Credentials Made By My Clearml Self-Hosted Web App. I Am Running The Web App Docker Container On A Rhel Server With The Ports As Described By Clearml’S Docs Open To Tcp I

Separate problem from the above. I cannot get the clearml-init command to accept credentials made by my clearml self-hosted web app.

I am running the web app docker container on a rhel server with the ports as described by clearml’s docs open to tcp

I can access the webpage, I can use the init command on credentials from the clearml non-self-hosted webpage, and I have confirmed they are on the same network

  
  
Posted one year ago
Votes Newest

Answers 8


Found the problem. Some port rules between my server and client was blocking it. Some autossh forwarding solved my problem

  
  
Posted one year ago

Hi @<1538330703932952576:profile|ThickSeaurchin47> , can you please add the input/output of the clearml-init command? Did you change any of the default ports?

  
  
Posted one year ago

And from the self-hosted ^

  
  
Posted one year ago

@<1523701070390366208:profile|CostlyOstrich36> , anything I missed?

  
  
Posted one year ago

clearml-init
ClearML SDK setup process

Please create new clearml credentials through the settings page in your clearml-server web app (e.g. None )
Or create a free account at None

In settings page, press "Create new credentials", then press "Copy to clipboard".

Paste copied configuration here:
api {
web_server: http://:8080
api_server: http://
:8008
files_server: http://:8081
credentials {
"access_key" = "
*"
"secret_key" = "
***"
}
}
Detected credentials key="
*************" secret="
*****"

ClearML Hosts configuration:
Web App: http://:8080
API: http://
:8008
File Store: http://*:8081

Verifying credentials ...
Retrying (Retry(total=1, connect=None, read=None, redirect=None, status=None)) after connection broken by 'ConnectTimeoutError(<urllib3.connection.HTTPConnection object at 0x7fa25dfc85e0>, 'Connection to * timed out. (connect timeout=3.0)')': /auth.login
Retrying (Retry(total=0, connect=None, read=None, redirect=None, status=None)) after connection broken by 'ConnectTimeoutError(<urllib3.connection.HTTPConnection object at 0x7fa25dfc8b80>, 'Connection to * timed out. (connect timeout=3.0)')': /auth.login
Error: could not verify credentials: key=******* secret=*****

  
  
Posted one year ago

None of the default ports are changed and in my firewalld I have ports 8080, 8081, and 8008 open to tcp

  
  
Posted one year ago

From running it with the credentials I got with the non-self-hosted clearml instance

clearml-init
ClearML SDK setup process

Please create new clearml credentials through the settings page in your clearml-server web app (e.g. None )
Or create a free account at None

In settings page, press "Create new credentials", then press "Copy to clipboard".

Paste copied configuration here:
api {
# Daniel Redder's workspace
web_server: None
api_server: None
files_server: None
credentials {
"access_key" = "*******"
"secret_key" = "
*********"
}
}
Detected credentials key="
*********" secret="
********"

ClearML Hosts configuration:
Web App: None
API: None
File Store: None

Verifying credentials ...
Credentials verified!

  
  
Posted one year ago

Firewall rules:
image

  
  
Posted one year ago
768 Views
8 Answers
one year ago
one year ago
Tags