Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
When I Run Clearml-Data To Create A New Dataset When First Setup The Clearml Server, I Got The Following Error: Root@Banglian-Virtual-Machine:~# Clearml-Data Create --Project Smoke --Name Smokedataset Clearml-Data - Dataset Management & Versioning Cli Cre

When I run clearml-data to create a new dataset when first setup the clearml server, I got the following error:
root@banglian-virtual-machine:~# clearml-data create --project Smoke --name SmokeDataset
clearml-data - Dataset Management & Versioning CLI
Creating a new dataset:

Error: Datasets are not supported with your current ClearML server version. Please update your server.

The server version is WebApp: 1.10.1-359 • Server: 1.10.1-359 • API: 2.24

  
  
Posted one year ago
Votes Newest

Answers 4


Thanks for you reply.
I am using the latest version 1.10 of clearml-server following the guide: None

  
  
Posted one year ago

Hi @<1572395190897872896:profile|ShortWhale75> , is it possible you're using a very old version of clearml package?

  
  
Posted one year ago

Hi, @<1523701070390366208:profile|CostlyOstrich36>
After I reconfig the clearml and recycle the clearml-server, the error is gone, I don't understand this behavior, but anyway, it's ok now, thanks~~

  
  
Posted one year ago

Hi, @<1523701070390366208:profile|CostlyOstrich36>
I reinstall the self-hosted clearml-server with 1.10 from the doc link: None .
And the WebApp is ok.
When I install clearml with "pip install clearml" from another machine, the installation is ok and clearml-init is also ok.
But when I run the clearml-data to create dataset, I got the above error.

root@BangLian:/usr/local/bin# pip3 uninstall clearml
Found existing installation: clearml 1.10.4
Uninstalling clearml-1.10.4:
  Would remove:
    /usr/local/bin/clearml-data
    /usr/local/bin/clearml-init
    /usr/local/bin/clearml-param-search
    /usr/local/bin/clearml-task
    /usr/local/lib/python3.8/dist-packages/clearml-1.10.4.dist-info/*
    /usr/local/lib/python3.8/dist-packages/clearml/*
Proceed (y/n)? y
  Successfully uninstalled clearml-1.10.4
root@BangLian:/usr/local/bin# pip3 install clearml
Collecting clearml
  Using cached clearml-1.10.4-py2.py3-none-any.whl (1.1 MB)
Requirement already satisfied: requests>=2.20.0 in /usr/lib/python3/dist-packages (from clearml) (2.22.0)
Requirement already satisfied: attrs>=18.0 in /usr/local/lib/python3.8/dist-packages (from clearml) (22.2.0)
Requirement already satisfied: python-dateutil>=2.6.1 in /usr/lib/python3/dist-packages (from clearml) (2.7.3)
Requirement already satisfied: pyparsing>=2.0.3 in /usr/local/lib/python3.8/dist-packages (from clearml) (3.0.9)
Requirement already satisfied: jsonschema>=2.6.0 in /usr/local/lib/python3.8/dist-packages (from clearml) (4.17.3)
Requirement already satisfied: Pillow>=4.1.1 in /usr/lib/python3/dist-packages (from clearml) (7.0.0)
Requirement already satisfied: urllib3>=1.21.1 in /usr/lib/python3/dist-packages (from clearml) (1.25.8)
Requirement already satisfied: furl>=2.0.0 in /usr/local/lib/python3.8/dist-packages (from clearml) (2.1.3)
Requirement already satisfied: pathlib2>=2.3.0 in /usr/local/lib/python3.8/dist-packages (from clearml) (2.3.7.post1)
Requirement already satisfied: pyjwt<2.5.0,>=2.4.0; python_version > "3.5" in /usr/local/lib/python3.8/dist-packages (from clearml) (2.4.0)
Requirement already satisfied: psutil>=3.4.2 in /usr/local/lib/python3.8/dist-packages (from clearml) (5.9.5)
Requirement already satisfied: PyYAML>=3.12 in /usr/lib/python3/dist-packages (from clearml) (5.3.1)
Requirement already satisfied: six>=1.13.0 in /usr/lib/python3/dist-packages (from clearml) (1.14.0)
Requirement already satisfied: numpy>=1.10 in /usr/local/lib/python3.8/dist-packages (from clearml) (1.24.3)
Requirement already satisfied: pkgutil-resolve-name>=1.3.10; python_version < "3.9" in /usr/local/lib/python3.8/dist-packages (from jsonschema>=2.6.0->clearml) (1.3.10)
Requirement already satisfied: pyrsistent!=0.17.0,!=0.17.1,!=0.17.2,>=0.14.0 in /usr/local/lib/python3.8/dist-packages (from jsonschema>=2.6.0->clearml) (0.19.3)
Requirement already satisfied: importlib-resources>=1.4.0; python_version < "3.9" in /usr/local/lib/python3.8/dist-packages (from jsonschema>=2.6.0->clearml) (5.12.0)
Requirement already satisfied: orderedmultidict>=1.0.1 in /usr/local/lib/python3.8/dist-packages (from furl>=2.0.0->clearml) (1.0.1)
Requirement already satisfied: zipp>=3.1.0; python_version < "3.10" in /usr/local/lib/python3.8/dist-packages (from importlib-resources>=1.4.0; python_version < "3.9"->jsonschema>=2.6.0->clearml) (3.15.0)
Installing collected packages: clearml
Successfully installed clearml-1.10.4


WebApp: 1.10.1-359 • Server: 1.10.1-359 • API: 2.24
  
  
Posted one year ago