Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hello Everyone! We Have Set Up A Self Hosted Clearml Server On An Azure Vm. Unfortunately, We Are Unsure About How The Configuration Of The Subdomains Should Be Done. The Dns Records Are Correctly Set, With Cname Pointing To The Server'S Ip For All Three

Hello everyone! We have set up a self hosted ClearML server on an Azure VM. Unfortunately, we are unsure about how the configuration of the subdomains should be done. The DNS records are correctly set, with CNAME pointing to the server's IP for all three subdomains (app. api. file.). Additionally, we have set up Nginx as a reverse proxy on the server. However, when trying to log in, we receive the the error in the attached image.
The Api server log looked like this:

[2023-06-29 10:41:49,551] [8] [INFO] [clearml.service_repo] Returned 200 for auth.login in 10ms
[2023-06-29 10:41:49,553] [8] [INFO] [clearml.service_repo] Returned 200 for auth.login in 10ms
[2023-06-29 10:41:49,664] [8] [WARNING] [clearml.service_repo] Returned 401 for users.get_preferences in 0ms, msg=Unauthorized (missing credentials)
[2023-06-29 10:41:49,809] [8] [WARNING] [clearml.service_repo] Returned 401 for users.get_current_user in 0ms, msg=Unauthorized (missing credentials)
[2023-06-29 10:41:49,810] [8] [WARNING] [clearml.service_repo] Returned 401 for server.report_stats_option in 0ms, msg=Unauthorized (missing credentials)
[2023-06-29 10:41:49,977] [8] [INFO] [clearml.service_repo] Returned 200 for users.get_all in 3ms

current serverconfig:

 auth {
   cookies {
     httponly: true
     secure: true
     domain: ".clearml.wesort.ai"
     max_age: 99999999999
   }
 }

and nginx site configuration:

server {
	listen 80;
	listen [::]:80;
	server_name api.clearml.wesort.ai;

	location / {
		proxy_set_header Host $host;
		proxy_set_header X-Real-IP $remote_addr;
		proxy_pass 
;
	}	

}
server {
	listen 80;
	listen [::]:80;
	server_name app.clearml.wesort.ai;

	location / {
		proxy_set_header Host $host;
		proxy_set_header X-Real-IP $remote_addr;
		proxy_pass 
;
	}	

}
server {
	listen 80;
	listen [::]:80;
	server_name files.clearml.wesort.ai;

	location / {
		proxy_set_header Host $host;
		proxy_set_header X-Real-IP $remote_addr;
		proxy_pass 
;
	}	

}

How should the configuration of the subdomain mode be done, Is Nginx even necessary? Is there a configuration guide available? I would appreciate any help!
image

  
  
Posted one year ago
Votes Newest

Answers 13


Hi @<1585441135088635904:profile|StoutShark79> , it seems to be the issue is related to the cookie - @<1523701827080556544:profile|JuicyFox94> any idea?

  
  
Posted one year ago

really weird, can you try to totally remove any cookie domain related?

  
  
Posted one year ago

Ok, let’s try to deep dive into it, what is the Helm chart version used for this deployment?

  
  
Posted one year ago

ok got it, are you able to access the system bypassing nginx with http://<Server Address>:8080 ?

  
  
Posted one year ago

Thank you for the swift response! yes, we are using docker-compose

  
  
Posted one year ago

moreover url exposed by nginx should be under https

  
  
Posted one year ago

Hello, @<1523701087100473344:profile|SuccessfulKoala55> and @<1523701827080556544:profile|JuicyFox94> , thank you for your responses! And please excuse my tardiness. Currently, we are not using Helm. We chose to deploy the ClearML Server in Linux using the pre-built Docker image.

  
  
Posted one year ago

Trying to access the system with http://<Server Address>:8080 yields the same error. Also, thank you for the HTTPS tip. We will fix that!

  
  
Posted one year ago

Did you applied any configuration to apiserver?

  
  
Posted one year ago

only:

 auth {
   cookies {
     httponly: true
     secure: true
     domain: ".clearml.wesort.ai"
     max_age: 99999999999
   }
 }
  
  
Posted one year ago

Ok that’s weird

  
  
Posted one year ago

so you are using docker-compose?

  
  
Posted one year ago

Sorry for the delay! Removing all cookies yields the same error. Interestingly, deleting the configuration file for the API server and setting up the Clearml server again without it seems to work. We are able to access the system with both http://<Server Address>:8080 and app.clearml.wesort.ai . However, when we set up the clearml server with the configuration file again, we return to encountering the error.

  
  
Posted one year ago
631 Views
13 Answers
one year ago
one year ago
Tags