Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Hi Everybody! I'M Running An Example Pipeline From A Web Ui. I Notice Very Strange Behavior. After The First Local Run, I Can Create A New Run And Pass Initialization Parameters There, But After A Successful Run, I Lose The Ability To Create New Runs With

Hi everybody! I'm running an example pipeline from a web UI. I notice very strange behavior. After the first local run, I can create a NEW RUN and pass initialization parameters there, but after a successful run, I lose the ability to create new runs with passing new parameters there.

As far as I understand, when I first start the server, the clearml can read the configuration parameters, but after the remote launch, it apparently loses this ability. Is there a possibility that the feedback from the server is broken during the remote start, or something should be corrected in the configuration file.

from clearml import PipelineDecorator

@PipelineDecorator.component(cache=True, execution_queue="default")
def step(size: int):
    import numpy as np
    return np.random.random(size=size)

    project='data processing',
def pipeline_logic(do_stuff: bool):
    if do_stuff:
        return step(size=42)

if __name__ == '__main__':
    # run the pipeline on the current machine, for local debugging
    # for scale-out, comment-out the following line (Make sure a
    # 'services' queue is available and serviced by a ClearML agent
    # running either in services mode or through K8S/Autoscaler)



Posted 4 months ago
Votes Newest

Answers 9

I had a similar behavior: the parameters for starting the pipeline are not selected in a detailes view, only in the table view

Posted 4 months ago

this is likely an UI bug. We should have a fix soon. In the meantime, yes, you can edit the configuration under the pipeline task to achieve the same effect

Posted 4 months ago

tasks that create pipelines feels like a hack and i found they dont show up in the UI (have to use the link in the console).

I've found that sometimes i need to right click "Run" a couple of times before the parameters are filled in properly.

Posted 4 months ago

No, I get start pipelines through cloning as tasks, it's less visual, but this way I can change all my hyperparameters

Posted 4 months ago

@<1578555761724755968:profile|GrievingKoala83> Did you solve this problem?

Posted 4 months ago

Yes, I see

Posted 4 months ago

@<1593051292383580160:profile|SoreSparrow36> @<1578555761724755968:profile|GrievingKoala83>
I found that if you go into the details of the pipeline, you can copy it manually and it will go into edit mode, where you can change the parameters manually

Posted 4 months ago

Hi @<1524560082761682944:profile|MammothParrot39> ! Do you see the parameter do_stuff under your pipeline controller's task?

Posted 4 months ago

@<1578555761724755968:profile|GrievingKoala83> I have the same problem with table and detailed view

Posted 4 months ago
9 Answers
4 months ago
4 months ago
Similar posts