Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
I'M Trying To Deploy The Open Source Clearml-Server, But I'M Running Into This Error: Traceback (Most Recent Call Last): File "/Usr/Local/Lib/Python3.9/Site-Packages/Pyhocon/Config_Parser.Py", Line 478, In _Resolve_Variable Return True, Config.Get(

I'm trying to deploy the open source ClearML-server, but I'm running into this error:

Traceback (most recent call last):
File "/usr/local/lib/python3.9/site-packages/pyhocon/config_parser.py", line 478, in _resolve_variable
return True, config.get(variable)
File "/usr/local/lib/python3.9/site-packages/pyhocon/config_tree.py", line 236, in get
return self._get(ConfigTree.parse_key(key), 0, default)
File "/usr/local/lib/python3.9/site-packages/pyhocon/config_tree.py", line 176, in _get
raise ConfigMissingException(
pyhocon.exceptions.ConfigMissingException: 'No configuration setting found for key CLEARML_FILES_HOST'

I've set an environment variable for it, but it's still showing this error. Any ideas on how to fix it?

  
  
Posted 7 months ago
Votes Newest

Answers 4


@<1600661428556009472:profile|HighCoyote66> which docker-compose version are you using? Note you can also use the --env-file
command line switch for docker-compose

  
  
Posted 7 months ago

Also, how did you set the env variable?

  
  
Posted 7 months ago

Ok thanks @<1523701070390366208:profile|CostlyOstrich36> . When I launched the docker-compose on my Ubuntu machine, I never even set the variable. We've since migrated to RHEL 8 so I'm using podman to launch it and this is the first I'm ever seeing this error. I found docs on it, so I set it using export ClEARML_FILES_HOST=" None " . For whatever reason that didn't work so I've just resorted to hardcoding it in the docker-compose.yml

  
  
Posted 7 months ago

Hi @<1600661428556009472:profile|HighCoyote66> , I think you need to set it in the docker compose.

  
  
Posted 7 months ago
551 Views
4 Answers
7 months ago
7 months ago
Tags