Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Hello Everyone, We Have Created A Cleaml Pipeline Using Pipelinecontroller. We Use Add_Function_Step To Add Tasks To The Pipeline. So As To Upload Artifacts Etc. Directly To S3 Bucket We Assign Bucket Path To The Output_Uri Parameter In The Add_Function_

Hello everyone,

We have created a cleaml pipeline using PipelineController.
We use add_function_step to add tasks to the pipeline.
So as to upload artifacts etc. directly to S3 bucket we assign
bucket path to the output_uri parameter in the add_function_step.

We want to totally avoid using fileserver, however even after passing
the S3 bucket path, it first saves the artifact to fileserver and then
uploads it to the bucket.
We also tried specifying the bucket path in the Clearml configuration file
under direct_access.

Posted 12 days ago
Votes Newest

Answers 2

Thanks @<1523701070390366208:profile|CostlyOstrich36> . We were only changing this for each output_uri, but this makes our lives a bit easier. Thanks :)

Posted 12 days ago

Hi @<1636537816684957696:profile|CooperativeGoat65> , you can change the api.files_server section of the configuration file to point to your s3 bucket

Posted 12 days ago
2 Answers
12 days ago
12 days ago
Similar posts