Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hello Everyone! I Cant Connect Clearml With Yandex Storage S3. I Have An Error With Keys And Permissions (See The Screenshots), But I Can Upload Model Weights On Yandex Storage S3 Without Clearml. Maybe I Have Problems With My Config? Could You Help Me, P

Hello everyone!
I cant connect ClearML with Yandex Storage S3. I have an error with keys and permissions (see the screenshots), but I can upload model weights on Yandex Storage S3 without ClearML. Maybe I have problems with my config? Could you help me, please?
image
image
image

  
  
Posted one month ago
Votes Newest

Answers 10


@<1523701435869433856:profile|SmugDolphin23> , I added setup_aws_upload and it didn't worked for me. Same error as in the screenshot.

None

Config is correct, credentials is correct. Maybe clearml doesn't worked with Yandex S3?

There is no Yandex S3 in documentation. None .

If it possible, which format of config I need to use? Config for aws - it doesn't contain an endpoint, so it's obviously not suitable.

Could you dive in a little and help me, please? Or say that this is not possible in the current version clearml.

  
  
Posted 25 days ago

Hi, @<1523701070390366208:profile|CostlyOstrich36> , thank you, but I think the problem is not in the config, I tested different config templates. About the port (like in a Minio): Yandex S3 Storage use standard 443 port for https connection. I tried this way too.

  
  
Posted one month ago

Hi, @<1523701435869433856:profile|SmugDolphin23> , thank you for answer. Here is my code snippet.

None

  
  
Posted one month ago

@<1675675705284759552:profile|NonsensicalAnt77> Can you try using None to setup the credentials? Maybe there is an issue parsing/finding the conf file

  
  
Posted one month ago

Hi @<1675675705284759552:profile|NonsensicalAnt77> , looks like a misconfiguration on your part.
Please see the documentation regarding S3 - None

Note that the way you configured this is for AWS S3, if you scroll down a bit there will be an example for S3 like solution such as minio, this is the configuration style you need, with the port

  
  
Posted one month ago

Hi @<1675675705284759552:profile|NonsensicalAnt77> ! How are you uploading the model weights without using the SDK? Can you please share a code snippet (might be useful in finding why your config doesn't work). Also, what is your clearml version?

  
  
Posted one month ago

@<1523701435869433856:profile|SmugDolphin23> , yes, I tried it, but the error is the same as in the screenshot 🤕

  
  
Posted one month ago

@<1675675705284759552:profile|NonsensicalAnt77> have you tried setting secure: true and host: storage.yandexcloud.net:443 ?

  
  
Posted one month ago

@<1523701435869433856:profile|SmugDolphin23> , yes, thank you very much, I will try and write to you!

  
  
Posted one month ago

@<1523701435869433856:profile|SmugDolphin23> , clearml version = 1.14.4. Could you help, please?

  
  
Posted one month ago