Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hi Im Getting This Error And I Have No Idea How To Solve It, Please Help

hi im getting this error and i have no idea how to solve it, please help
ERROR: Could not find a version that satisfies the requirement pandas==1.4.0 (from -r /tmp/cached-reqsxkwqp2ds.txt (line 2)) (from versions: 0.1, 0.2, 0.3.0, 0.4.0, 0.4.1, 0.4.2, 0.4.3, 0.5.0, 0.6.0, 0.6.1, 0.7.0, 0.7.1, 0.7.2, 0.7.3, 0.8.0, 0.8.1, 0.9.0, 0.9.1, 0.10.0, 0.10.1, 0.11.0, 0.12.0, 0.13.0, 0.13.1, 0.14.0, 0.14.1, 0.15.0, 0.15.1, 0.15.2, 0.16.0, 0.16.1, 0.16.2, 0.17.0, 0.17.1, 0.18.0, 0.18.1, 0.19.0, 0.19.1, 0.19.2, 0.20.0, 0.20.1, 0.20.2, 0.20.3, 0.21.0, 0.21.1, 0.22.0, 0.23.0, 0.23.1, 0.23.2, 0.23.3, 0.23.4, 0.24.0, 0.24.1, 0.24.2, 0.25.0, 0.25.1, 0.25.2, 0.25.3, 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.0.5, 1.1.0, 1.1.1, 1.1.2, 1.1.3, 1.1.4, 1.1.5, 1.2.0, 1.2.1, 1.2.2, 1.2.3, 1.2.4, 1.2.5, 1.3.0, 1.3.1, 1.3.2, 1.3.3, 1.3.4, 1.3.5) ERROR: No matching distribution found for pandas==1.4.0 (from -r /tmp/cached-reqsxkwqp2ds.txt (line 2)) clearml_agent: ERROR: Could not install task requirements! Command '['/root/.clearml/venvs-builds/3.7/bin/python', '-m', 'pip', '--disable-pip-version-check', 'install', '-r', '/tmp/cached-reqsxkwqp2ds.txt']' returned non-zero exit status 1.Iā€™m running the task from pipeline, and this is from the task
task = Task.init(project_name=PROJECT_NAME, task_name=TASK_NAME) task.set_base_docker("pytorch/pytorch")

  
  
Posted 2 years ago
Votes Newest

Answers 10


What is the exact python version you're trying to run on?

  
  
Posted 2 years ago

Warning: could not locate requested Python version 3.8, reverting to version 3.7

  
  
Posted 2 years ago

do u think this could be the error?

  
  
Posted 2 years ago

Usually pands has different versions for different python versions, so most likely the pandas version specified in the requirements can't be located for python 3.7

  
  
Posted 2 years ago

you can simply change the required pandas version in the requirements section and try again

  
  
Posted 2 years ago

ok let me pin pandas version to 1.3.5 and see if it works, thanks

  
  
Posted 2 years ago

SuccessfulKoala55 alright, it turns out my local python version is mismatched with the python version in the docker image i defined. Question - why is this the expected behavior?

  
  
Posted 2 years ago

I'm not sure I understand the question šŸ™‚

  
  
Posted 2 years ago

it is ok, please ignore the question. šŸ™ƒ

  
  
Posted 2 years ago

Question - why is this the expected behavior?

It is šŸ™‚ I mean the original python version is stored, but pip does not support replacing python version. It is doable with conda, but than you have to use conda for everything...

  
  
Posted 2 years ago
531 Views
10 Answers
2 years ago
one year ago
Tags
Similar posts