Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
Hi All, I Am Using A Self-Hosted Clearml Instance. I'M Exploring The Report Feature And Ran Into A Bug. Steps To Reproduce:

Hi all, I am using a self-hosted clearml instance. I'm exploring the report feature and ran into a bug.

Steps to reproduce:

  • Have self-hosted ClearML instance
  • Create a report
  • Upload image from device via the UI button
    Error:
  • Upload failedCannot read properties of undefined (reading 'toLowerCase')
    image
  
  
Posted one month ago
Votes Newest

Answers 13


I'm using the latest ClearML image from docker; I'm running it on a linux machine and followed those steps for the most part when deploying. Here is the stack trace from the client:
image

  
  
Posted one month ago

No I don't. The key files_server doesn't exist in the credentials. When I create credentials I've been correcting the endpoints for the api_server and files_server each time.

  
  
Posted one month ago

and did you see any error in the browser console (F12)

  
  
Posted one month ago

what version of ClearML are you using?

  
  
Posted one month ago

Hi,

  
  
Posted one month ago

I'm running the default ports, 8080, 8081, and 8008 for the webserver, fileserver, and apiserver, respectively. I just modifed the deployment and sat a proxy in front of it so I could expose it to the internet and use it elsewhere. My current configuration involves doing this, where I change the values for the api_server and files_server to use the URL endpoints instead of the ports directly:

api {
    web_server: 

    api_server: 

    files_server: 

}
  
  
Posted one month ago

I'll need to check how to configure the UI for this type of deployment as the UI has just a few configurations it can guess the files server URL from.

  
  
Posted one month ago

I'm also using these versions of ClearML
image

  
  
Posted one month ago

which port are you running clearml of?

  
  
Posted one month ago

Hi @<1600661428556009472:profile|HighCoyote66> , I'm not sure I understand, can you please elaborate on this?

  • Upload image from device via the UI buttonWhat do you mean by device?
  
  
Posted one month ago

if you open the help menu on the top and click "clearml python package setup" then "create new credentials"
do you see the right value for files_server in the suggested config?

  
  
Posted one month ago

Hi @<1523701070390366208:profile|CostlyOstrich36> , thanks for replying. I'm referring to the upload option from local device. When I click this button a file explorer pops up so I'm assuming it's intended to allow image uploads from my local machine
image

  
  
Posted one month ago

Sounds good. I've looked into the configuration settings information, is this a problem because I didn't set the CLEARML_FILES_HOST env variable in an env file somewhere? With the autogenerated credientials, the api_server gets generated, but it points to None instead, so I have to fix it. Whereas, the files_server key does not even appear.

  
  
Posted one month ago
106 Views
13 Answers
one month ago
one month ago
Tags