Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escaping: Escape characters +-&|!(){}[]^"~*?:\ with \, e.g. \+
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
How Do I View Debug Samples Images In The Browser When The Output_Uri Is On Google Cloud Storage (

How do I view Debug Samples images in the browser when the output_uri is on Google Cloud Storage ( None )?
Unlike for AWS storage, I do not get a popup window asking me for credentials, but just get that warning sign (see screenshot below.)
The image was successfully uploaded and is even publicly available ( link in this case ).
image

  
  
Posted 11 months ago
Votes Newest

Answers 18


it might have some mixed or insecure content blocked

  
  
Posted 11 months ago

Yes and yes - is that the issue and it might likely go away if we host it via HTTPS?

  
  
Posted 11 months ago

I’m on Safari actually, but I just checked on Chrome (which shows this unsecure connection indicator) and images are activated. Might it still be due to non-HTTPS connection? We should get on that anyhow

  
  
Posted 11 months ago

try to open site settings in the (i) menu
image

  
  
Posted 11 months ago

yes, browsers usually block accessing insecure data on secure site and vise versa

  
  
Posted 11 months ago

in your case clearml is insecure and GCS is secure

  
  
Posted 11 months ago

I think so, I guess you're using chrome

  
  
Posted 11 months ago

Hi, maybe this is related None ?

  
  
Posted 8 months ago

Ok I see, that is what I thought. But do you have any idea why I am not seeing these images? I am logged into my Gmail account and into the Google Cloud Console and can access both in another tab of the same browser. Am I missing something here?

  
  
Posted 10 months ago

Hi @<1523702496097210368:profile|ScantChimpanzee51> , currently we rely on a GCP token to be available on this session. in your case a private windows is a new separate session.
we consider signing GCP resources similar to AWS, in a future version

  
  
Posted 10 months ago

If that helps: The URL I get when I copy it out of the ClearML dashboard is the same one as is listed under “Authenticated URL” when looking up the image in Google Cloud storage. And of course that opens the image if I go to it in another tab

  
  
Posted 10 months ago

Hi @<1523702496097210368:profile|ScantChimpanzee51> , I think you need to be connected to the GS account on the same machine

  
  
Posted 11 months ago

@<1523701070390366208:profile|CostlyOstrich36> , you mean the ClearML server needs access to Cloud Storage in its clearml.conf file?
Just tried it by creating a ~/clearml.conf file and setting the entry as below - unfortunately the same result. I’ve re-started the docker-compose of course.

Did I miss something here?

    google.storage {
        credentials_json: "/home/.../my-crendetials.json"
    }
  
  
Posted 11 months ago

Ah got it - that is already the case though. I’m logged into a Google Account that can access that bucket and I can download the image by clicking on the Download link in the ClearML dashboard and by going through the GCP console to the bucket…

  
  
Posted 11 months ago

No, no I mean you need to be logged into your GS account on the same browser as the webserver when visiting

  
  
Posted 11 months ago

It was related, special characters also made prevented some access.
But it was and is also related to some authentication problem with Google: If you open the dashboard in Chrome, go to the developer console, you see a bunch of failed links to authenticate to. If you click one of them in another tab, it shows the Google signin screen and afterwards you can see the Debug Samples in Dashboard.
That all does not work in safari though for some reason 🙂

  
  
Posted 8 months ago

Hi @<1523703436166565888:profile|DeterminedCrab71> and @<1523701070390366208:profile|CostlyOstrich36> , coming back to this after a while. It actually seems to be related to Google Cloud permissions:

  • The images in the ClearML dashboard to not show as discussed above
  • If I copy the image url (coming out as something like None and open it in another tab where I’m logged into my Google Account, the image loads
  • If I do the same thing in a private tab or other browser where I’m not logged into my Google account, the error page comes as shown below.I still haven’t set Google Cloud credentials in the ClearML dashboard like I needed to do for AWS - is there any way to do the equivalent for GCP?
    image
  
  
Posted 10 months ago

Hi @<1523702496097210368:profile|ScantChimpanzee51> , is clearml self hosted and if so, is it on a non secure (HTTP) server?

  
  
Posted 11 months ago